summaryrefslogtreecommitdiff
path: root/app-misc/pax-utils/pax-utils-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 12:11:06 +0000
commit29efd7db303b443e103311cc0e458ee5c134e8e5 (patch)
treecb6e3ef15df82575a93cae8bd11b635d473f3796 /app-misc/pax-utils/pax-utils-9999.ebuild
parent19a808581ca18addf4b12d09f7e440b7244679e5 (diff)
gentoo auto-resync : 06:01:2023 - 12:11:06
Diffstat (limited to 'app-misc/pax-utils/pax-utils-9999.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-9999.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-misc/pax-utils/pax-utils-9999.ebuild b/app-misc/pax-utils/pax-utils-9999.ebuild
index 9aae26cb7eaf..599c1ab4a187 100644
--- a/app-misc/pax-utils/pax-utils-9999.ebuild
+++ b/app-misc/pax-utils/pax-utils-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,39 +17,37 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pax-utils.git"
inherit git-r3
else
- SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~sam/distfiles/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ SRC_URI="
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ "
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
LICENSE="GPL-2"
SLOT="0"
IUSE="caps +man python seccomp test"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( python )
+"
+RESTRICT="!test? ( test )"
-_PYTHON_DEPS="
+MY_PYTHON_DEPS="
${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pyelftools[${PYTHON_USEDEP}]
')
"
-
-RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
- python? ( ${_PYTHON_DEPS} )
+RDEPEND="
+ caps? ( >=sys-libs/libcap-2.24 )
+ python? ( ${MY_PYTHON_DEPS} )
"
DEPEND="${RDEPEND}"
BDEPEND="
caps? ( virtual/pkgconfig )
man? ( app-text/xmlto )
-
- python? ( ${_PYTHON_DEPS} )
-"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- test? ( python )
-"
-RESTRICT="
- !test? ( test )
+ python? ( ${MY_PYTHON_DEPS} )
"
pkg_setup() {