summaryrefslogtreecommitdiff
path: root/app-misc/pax-utils/pax-utils-1.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-misc/pax-utils/pax-utils-1.2.6.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-misc/pax-utils/pax-utils-1.2.6.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-1.2.6.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/app-misc/pax-utils/pax-utils-1.2.6.ebuild b/app-misc/pax-utils/pax-utils-1.2.6.ebuild
deleted file mode 100644
index a3e63fcd1d5c..000000000000
--- a/app-misc/pax-utils/pax-utils-1.2.6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit eutils python-single-r1 toolchain-funcs
-
-DESCRIPTION="ELF utils that can check files for security relevant properties"
-HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug kernel_linux python seccomp"
-
-RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]
- ')
- )
- seccomp? ( sys-libs/libseccomp )
-"
-# >=linux-headers-4.11 to pick linux headers with statx, bug #737094
-DEPEND="
- ${RDEPEND}
- kernel_linux? ( !prefix-guest? ( >=sys-kernel/linux-headers-4.11 ) )
-"
-BDEPEND="
- caps? ( virtual/pkgconfig )
- seccomp? ( virtual/pkgconfig )
-"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-_emake() {
- emake \
- USE_CAP=$(usex caps) \
- USE_DEBUG=$(usex debug) \
- USE_PYTHON=$(usex python) \
- USE_SECCOMP=$(usex seccomp) \
- "$@"
-}
-
-pkg_setup() {
- if use python; then
- python-single-r1_pkg_setup
- fi
-}
-
-src_configure() {
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux ||
- has_version '<sys-libs/glibc-2.10'
- then
- econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
- else
- tc-export CC PKG_CONFIG
- fi
-}
-
-src_compile() {
- _emake
-}
-
-src_test() {
- _emake check
-}
-
-src_install() {
- _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
-
- use python && python_fix_shebang "${ED}"/usr/bin/lddtree
-}