summaryrefslogtreecommitdiff
path: root/app-misc/note/note-1.3.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/note/note-1.3.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/note/note-1.3.3-r1.ebuild')
-rw-r--r--app-misc/note/note-1.3.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-misc/note/note-1.3.3-r1.ebuild b/app-misc/note/note-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..35fba906d5da
--- /dev/null
+++ b/app-misc/note/note-1.3.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="A note taking perl program"
+HOMEPAGE="http://www.daemon.de/NOTE"
+SRC_URI="http://www.daemon.de/files/mirror/ftp.daemon.de/scip/Apps/note/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="crypt dbm general mysql text"
+
+DEPEND="dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl
+ virtual/perl-Storable
+ dev-perl/Config-General
+ crypt? ( dev-perl/Crypt-CBC
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES )
+ mysql? ( virtual/mysql
+ dev-perl/DBD-mysql )"
+RDEPEND=""
+
+src_install() {
+ perl-module_src_install
+
+ # Adding some basic utitily for testing note
+ dodir /usr/share/${PN}
+ cp "${S}/bin/stresstest.sh" "${D}/usr/share/${PN}"
+
+ # Adding some help for mysql backend driver
+ if use mysql; then
+ dodir /usr/share/${PN}/mysql
+ cp -r "${S}/mysql" "${D}/usr/share/${PN}"
+ fi
+
+ # Adding a sample configuration file
+ dodir /etc
+ cp "${S}/config/noterc" "${D}/etc"
+
+ # Supressing file not needed
+ for v in mysql text dbm general; do
+ if ! use ${v}; then
+ for u in `find "${D}" -type f -name *${v}.*pm`; do
+ rm "${u}"
+ done
+ fi
+ done
+
+ dodoc UPGRADE VERSION
+}