summaryrefslogtreecommitdiff
path: root/app-misc/note/note-1.3.26.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-misc/note/note-1.3.26.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-misc/note/note-1.3.26.ebuild')
-rw-r--r--app-misc/note/note-1.3.26.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/note/note-1.3.26.ebuild b/app-misc/note/note-1.3.26.ebuild
new file mode 100644
index 000000000000..94a63b164318
--- /dev/null
+++ b/app-misc/note/note-1.3.26.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="A note taking perl program"
+HOMEPAGE="https://www.daemon.de/NOTE"
+SRC_URI="https://www.daemon.de/idisk/Apps/note/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt dbm general mysql text"
+
+DEPEND="
+ dev-perl/Config-General
+ dev-perl/TermReadKey
+ dev-perl/Term-ReadLine-Perl
+ dev-perl/YAML
+ virtual/perl-Storable
+ crypt? (
+ dev-perl/Crypt-CBC
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-DES
+ )
+ mysql? ( dev-perl/DBD-mysql )
+"
+RDEPEND="${DEPEND}"
+
+# extraneous README that gets installed into the perl module
+PERL_RM_FILES=( NOTEDB/README )
+
+src_prepare() {
+ # Supressing file not needed
+ local v
+ for v in mysql text dbm general; do
+ if ! use ${v}; then
+ PERL_RM_FILES+=( NOTEDB/${v}.pm )
+ fi
+ done
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Adding some basic utitily for testing note
+ exeinto /usr/share/${PN}
+ doexe bin/stresstest.sh
+
+ # Adding some help for mysql backend driver
+ if use mysql; then
+ insinto /usr/share/${PN}/mysql
+ exeinto /usr/share/${PN}/mysql
+ doins mysql/{README,sql,permissions}
+ doexe mysql/install.sh
+ fi
+
+ # Adding a sample configuration file
+ insinto /etc
+ doins config/noterc
+
+ dodoc UPGRADE VERSION
+}