summaryrefslogtreecommitdiff
path: root/app-misc/notary/notary-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /app-misc/notary/notary-0.7.0.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'app-misc/notary/notary-0.7.0.ebuild')
-rw-r--r--app-misc/notary/notary-0.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/notary/notary-0.7.0.ebuild b/app-misc/notary/notary-0.7.0.ebuild
new file mode 100644
index 000000000000..141759da1bd1
--- /dev/null
+++ b/app-misc/notary/notary-0.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=b0b6bfdd
+
+DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
+HOMEPAGE="https://github.com/theupdateframework/notary"
+SRC_URI="https://github.com/theupdateframework/notary/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-group/notary
+ acct-user/notary
+"
+BDEPEND="${RDEPEND}"
+
+src_compile() {
+ emake GITCOMMIT=${GIT_COMMIT} NOTARY_VERSION=${PV} binaries
+}
+
+src_install() {
+ dobin bin/${PN}{,-server,-signer}
+ insinto /var/lib/notary
+ doins -r migrations fixtures
+ fowners -R ${PN}:${PN} /var/lib/notary
+ fperms -R 0600 /var/lib/notary/fixtures/database/
+ newinitd "${FILESDIR}"/notary-signer.initd notary-signer
+ newconfd "${FILESDIR}"/notary-signer.confd notary-signer
+ newinitd "${FILESDIR}"/notary-server.initd notary-server
+ newconfd "${FILESDIR}"/notary-server.confd notary-server
+}