summaryrefslogtreecommitdiff
path: root/app-misc/notary/notary-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /app-misc/notary/notary-0.6.1-r1.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'app-misc/notary/notary-0.6.1-r1.ebuild')
-rw-r--r--app-misc/notary/notary-0.6.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/notary/notary-0.6.1-r1.ebuild b/app-misc/notary/notary-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..00221646040f
--- /dev/null
+++ b/app-misc/notary/notary-0.6.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot golang-build user
+
+KEYWORDS="~amd64"
+DESCRIPTION="A project that allows anyone to have trust over arbitrary collections of data"
+EGO_PN="github.com/theupdateframework/notary"
+GIT_COMMIT="d6e1431feb32348e0650bf7551ac5cffd01d857b"
+
+HOMEPAGE="https://github.com/theupdateframework/notary"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary-server || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary-signer || die
+ GOPATH=${S} go install -v -tags pkcs11 -ldflags "-w -X ${EGO_PN}/version.GitCommit=${GIT_COMMIT} -X ${EGO_PN}/version.NotaryVersion=${PV}" \
+ ${EGO_PN}/cmd/notary || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/${PN}{,-server,-signer}
+ pushd src/${EGO_PN} || die
+ insinto /var/lib/notary
+ doins -r migrations fixtures
+ fowners -R ${PN}:${PN} /var/lib/notary
+ fperms -R 0600 /var/lib/notary/fixtures/database/
+ newinitd "${FILESDIR}"/notary-signer.initd notary-signer
+ newconfd "${FILESDIR}"/notary-signer.confd notary-signer
+ newinitd "${FILESDIR}"/notary-server.initd notary-server
+ newconfd "${FILESDIR}"/notary-server.confd notary-server
+}