summaryrefslogtreecommitdiff
path: root/app-misc/neofetch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-misc/neofetch
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-misc/neofetch')
-rw-r--r--app-misc/neofetch/Manifest4
-rw-r--r--app-misc/neofetch/neofetch-7.1.0.ebuild19
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild19
3 files changed, 38 insertions, 4 deletions
diff --git a/app-misc/neofetch/Manifest b/app-misc/neofetch/Manifest
index 0aa9871890c3..83a21e2b53dd 100644
--- a/app-misc/neofetch/Manifest
+++ b/app-misc/neofetch/Manifest
@@ -1,4 +1,4 @@
DIST neofetch-7.1.0.tar.gz 95400 BLAKE2B 32368d461835d95ba8203c560b2f6733594966cbaf809d877a46c08675284288565e3a21b14d94900dd66b778dc975339196f182732e2cd8bc1ccc9e6da6253e SHA512 fe1013fb54585c15ba556054478a2c8c503120387e81bd16bfdfbb6f3a188ed4124585540abf43da9209cbbe0d7fb90d50914cd6620137d00f013cfb6954a042
-EBUILD neofetch-7.1.0.ebuild 651 BLAKE2B 77992a147b2dedde0d28eb14f3b10d89f607770f3e0c6b8a4da9814467b4af62e485ec30bce3829828218982f15d67d896e4036786e6b3687a19baa246e31863 SHA512 88bb1cb2ec51aa67916e6d23ceb74b98ee7b92c8b59011b5fb06f647ec83184d6be45f1d547783bcf810903effcfb207389e3470b88104a93c747d5a8fd450f2
-EBUILD neofetch-9999.ebuild 653 BLAKE2B 0d40cc8f12b087114ca00f1710a0d557d1e970bda2a13ccd8f92fb696b804fde8965f85b71521e897b33fe79a18886e29959271a7a659b2e0cf64e46b660b0cd SHA512 eade9468c4c443ddc4edd8223bc80d68ce4751c8907f1785a64fbfb5db04886c49b3ef89e03b0dffd15336715fad54a97f18a945002a2ce169dedf7baf7a47cb
+EBUILD neofetch-7.1.0.ebuild 937 BLAKE2B 72424ef48458c2c4c0a70900f42f597ebaf0ec659b3fadc9e860262b336d066786b078412c363394c674250d52fcb2ab267c665d2778b98cea96a1baf759134c SHA512 568336106a81b75f35e657c7f494e6b1b7683dbba29085bc28c0e7b441d288c5a013ba3c6ebd1ad62b3862ec8ad835b6fcea07eb0dcd590b907c38f4427d79aa
+EBUILD neofetch-9999.ebuild 939 BLAKE2B a9e42345b9a4a07ada01f8f5a3b38749c58673059fc256506cb73334e632237e7824caf3b33c5b4d2b1aecfa78bfaf5f010b6babd5efd3ebef3ebc6ba7cb842e SHA512 c4d7d5aa941269102ef16f071a0ce92717f3975d41d89adf2a986d47e848de5fe912cdd1c3739bc2325b2d60d86ec8c9d2eacd53d687a1baed5b4950676e31a2
MISC metadata.xml 832 BLAKE2B c92c163b1e21732707fa19bcaf9bae3de4fb2affe29d8076cd36ccdb68e9f3409ac00db0b2e4bfaec02dbd15817de343ddd4b622b04aec83a05e1c3f87575a34 SHA512 8a81813a52396aa002730820d743f52baa96dda5e5ae8bf4c5058b80f04fcc7948e02839515a76d241b8064f77c02517806c1f1b94d8b59917c4fefcc8f8154a
diff --git a/app-misc/neofetch/neofetch-7.1.0.ebuild b/app-misc/neofetch/neofetch-7.1.0.ebuild
index 1b5936a85115..233fd2db7367 100644
--- a/app-misc/neofetch/neofetch-7.1.0.ebuild
+++ b/app-misc/neofetch/neofetch-7.1.0.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit prefix
+
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
KEYWORDS="amd64 ~arm64 ~mips ~ppc64 x86"
@@ -26,3 +28,18 @@ RDEPEND="sys-apps/pciutils
x11-apps/xrandr
x11-apps/xwininfo
)"
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index 2b82020241d3..b5f654d39b3b 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit prefix
+
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~mips ~ppc64 ~x86"
@@ -26,3 +28,18 @@ RDEPEND="sys-apps/pciutils
x11-apps/xrandr
x11-apps/xwininfo
)"
+
+src_prepare() {
+ if use prefix; then
+ # bug #693526
+ hprefixify neofetch
+ sed -e "/has emerge/s:\${br_prefix}:${EPREFIX}:" -i neofetch \
+ || die "Failed to adjust for Prefix"
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}