summaryrefslogtreecommitdiff
path: root/app-misc/mvcase/mvcase-0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /app-misc/mvcase/mvcase-0.1-r2.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'app-misc/mvcase/mvcase-0.1-r2.ebuild')
-rw-r--r--app-misc/mvcase/mvcase-0.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/mvcase/mvcase-0.1-r2.ebuild b/app-misc/mvcase/mvcase-0.1-r2.ebuild
new file mode 100644
index 000000000000..568fed8c4a02
--- /dev/null
+++ b/app-misc/mvcase/mvcase-0.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modified version of mv, used to convert filenames to lower/upper case"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/file"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-libs/shhopt"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-includes.patch"
+ "${FILESDIR}/${P}-flags.patch"
+)
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}