summaryrefslogtreecommitdiff
path: root/app-misc/mvcase/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/mvcase/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/mvcase/files')
-rw-r--r--app-misc/mvcase/files/mvcase-0.1-flags.patch25
-rw-r--r--app-misc/mvcase/files/mvcase-0.1-includes.patch25
2 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/mvcase/files/mvcase-0.1-flags.patch b/app-misc/mvcase/files/mvcase-0.1-flags.patch
new file mode 100644
index 000000000000..e0a9e99160f8
--- /dev/null
+++ b/app-misc/mvcase/files/mvcase-0.1-flags.patch
@@ -0,0 +1,25 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Wed Nov 14 23:22:15 UTC 2012
+Subject: build system
+
+ respect CC, CFLAGS and LDFLAGS
+
+--- mvcase-0.1/Makefile
++++ mvcase-0.1/Makefile
+@@ -6,14 +6,13 @@
+ MANPATH=/usr/man
+ COMPILE=gcc
+ ROFF=groff
+-CFLAGS=
+-CLIBS=-lshhopt
++LIBS=-lshhopt
+ INSTALL=install
+
+ all: mvcase mvcase.1.gz
+
+ mvcase: mvcase.c
+- $(COMPILE) $(CFLAGS) mvcase.c -o mvcase $(CLIBS)
++ $(CC) $(CFLAGS) mvcase.c -o mvcase $(LDFLAGS) $(LIBS)
+
+ mvcase.1.gz: mvcase.1
+ $(ROFF) -man -Tascii mvcase.1 | gzip > mvcase.1.gz
diff --git a/app-misc/mvcase/files/mvcase-0.1-includes.patch b/app-misc/mvcase/files/mvcase-0.1-includes.patch
new file mode 100644
index 000000000000..095f07a06780
--- /dev/null
+++ b/app-misc/mvcase/files/mvcase-0.1-includes.patch
@@ -0,0 +1,25 @@
+* Fix compiler warnings.
+* Remove unused variable.
+
+--- a/mvcase.c
++++ b/mvcase.c
+@@ -17,6 +17,10 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h> /* exit() free() realloc() */
++#include <string.h> /* strlen() strcpy() */
++#include <strings.h> /* rindex() */
++#include <ctype.h> /* tolower() toupper() */
+ #include <shhopt.h>
+
+ #define VERSION_INT 0
+@@ -45,7 +45,7 @@
+
+ int main (int argc, char **argv)
+ {
+- int i,j,k;
++ int i,j;
+ int static flag_upper = 0;
+ int static flag_lower = 0;
+ int static flag_path = 0;