summaryrefslogtreecommitdiff
path: root/app-misc/mtail/mtail-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /app-misc/mtail/mtail-1.2.0.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'app-misc/mtail/mtail-1.2.0.ebuild')
-rw-r--r--app-misc/mtail/mtail-1.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/mtail/mtail-1.2.0.ebuild b/app-misc/mtail/mtail-1.2.0.ebuild
new file mode 100644
index 000000000000..e6a4e3c5e34c
--- /dev/null
+++ b/app-misc/mtail/mtail-1.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Tail workalike, that performs output colourising"
+HOMEPAGE="http://matt.immute.net/src/mtail/"
+SRC_URI="
+ http://matt.immute.net/src/mtail/mtail-${PV}.tgz
+ http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( CHANGES "${PN}rc.sample" README "${DISTDIR}"/mtailrc-syslog.sample )
+
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}