summaryrefslogtreecommitdiff
path: root/app-misc/mswinurl_launcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/mswinurl_launcher
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/mswinurl_launcher')
-rw-r--r--app-misc/mswinurl_launcher/Manifest4
-rw-r--r--app-misc/mswinurl_launcher/metadata.xml11
-rw-r--r--app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild54
3 files changed, 69 insertions, 0 deletions
diff --git a/app-misc/mswinurl_launcher/Manifest b/app-misc/mswinurl_launcher/Manifest
new file mode 100644
index 000000000000..6469d842795a
--- /dev/null
+++ b/app-misc/mswinurl_launcher/Manifest
@@ -0,0 +1,4 @@
+DIST mswinurl_launcher-1.0.tar.gz 1289 SHA256 687172bf0817fa3910da7b52cbbdcb0d5b2f95757f8b35db84884310355ae76e SHA512 60435b78dc88ff3e6f780ef42a975eaedc2f515168ba1c6c3fc8b38f87ea5ad4d70d975825877233bae1c5f9c6a521d1c12d301683c9e3e705d18c6c26ce4f86 WHIRLPOOL 46613a71002a842fc66993dc7007bcc3dcc144591abc0d4afb4802757b0bcf636ff9e73d0d16c0be5cf675aed8b5e7348e33a92ccc84f7ef30c9842952ad3d77
+EBUILD mswinurl_launcher-1.0.ebuild 1262 SHA256 c7febdbbcef525b90e43be797457c56bf3f4a8314eb2b31be94fa2d01eeb57c7 SHA512 c02406dd4dda8e19de8fa8eeec5788aff4b225197be20333a011347ef4fcae305ceddb0cef91892c769fd36126ac6a93f54d91138f4fb49561adbf2221317466 WHIRLPOOL 0e39d1bd7b4d8d5f00a53a6446b5cb5d50a3bb34b5bfb81347d06089bdc6421de40fd078617d3f1098d4858738339e84d7b0195c75da7233c1ef57bdf5c3515a
+MISC ChangeLog 1617 SHA256 f374ee4385509b5f28eef612f464d094708c9dc1b5aa7164c2374de261f05f35 SHA512 492a9ccf1838f5309fc16731a5da87f0b8eac00a4e4db8e22377f73ddafc3a336df4c95055c5e24fa862257c7fda0206f9dd7f126aaba224bcf6ebc86acfc92f WHIRLPOOL ab461452926575ed288569a08e2d3cfb238ad0a7374576d00a08ed0413bea79eb77620f14dbeb58752b3751173ebd30539a863e22a48063b799610ef49204d44
+MISC metadata.xml 471 SHA256 0e1250d7f8bb21d56c408405ae01b0744a3d1a1b456861544e1feae27d1fdf24 SHA512 b652b77215d654a98929762ac6d5780cd9ffc74a47b4dab349913228652a380ed876ce451558588533906f02ec06bb48ede0a937decb942b124933c1a1cfce34 WHIRLPOOL 0e0ed6337d7227028b6adc0afd4b762c94f4d35182aebb16b1282db3e9c6394559c136e6c27cc508dc20003ee78a556607b4ecbfbe6c9bc62154795485b5f3ce
diff --git a/app-misc/mswinurl_launcher/metadata.xml b/app-misc/mswinurl_launcher/metadata.xml
new file mode 100644
index 000000000000..6fa1cc244d22
--- /dev/null
+++ b/app-misc/mswinurl_launcher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>axs@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<longdescription>
+This is a simple launcher script and .desktop entry to associate MS Windows *.URL (text/x-uri)
+files on linux DEs so that they will open in the configured default web browser.</longdescription>
+</pkgmetadata>
diff --git a/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild b/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
new file mode 100644
index 000000000000..2faf9f6a54d6
--- /dev/null
+++ b/app-misc/mswinurl_launcher/mswinurl_launcher-1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils fdo-mime python-r1
+
+GIST_STRING="77635-a46707715aa2e112d2ea5ec26771030ff5e7eb64"
+
+DESCRIPTION="Launcher and desktop association for MS Windows *.URL (text/x-uri) files"
+HOMEPAGE="https://gist.github.com/endolith/77635"
+SRC_URI="https://gist.github.com/endolith/${GIST_STRING/-//archive/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="mirror"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils"
+
+S="${WORKDIR}"/$GIST_STRING
+
+src_install() {
+ dobin ${PN}.py
+ python_replicate_script "${ED%/}"/usr/bin/${PN}.py
+
+ cat <<DESKTOP_EOF >"${T}"/${PN}.desktop
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=MS Windows URL file launcher
+Comment=Python script to parse and launch .url files (html links) from MS Windows
+NoDisplay=true
+Terminal=false
+TryExec=mswinurl_launcher.py
+Exec=mswinurl_launcher.py %F
+Icon=text-html
+MimeType=text/x-uri;
+DESKTOP_EOF
+ domenu "${T}"/${PN}.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}