summaryrefslogtreecommitdiff
path: root/app-misc/media-player-info/media-player-info-24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-misc/media-player-info/media-player-info-24.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-misc/media-player-info/media-player-info-24.ebuild')
-rw-r--r--app-misc/media-player-info/media-player-info-24.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/media-player-info/media-player-info-24.ebuild b/app-misc/media-player-info/media-player-info-24.ebuild
new file mode 100644
index 000000000000..a9f5a6034635
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-24.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1
+
+DESCRIPTION="Repository of data files describing media player capabilities"
+HOMEPAGE="https://gitlab.freedesktop.org/media-player-info/media-player-info"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+# Upstream commit d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT}"
+ # Upstream commit 1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
+}