summaryrefslogtreecommitdiff
path: root/app-misc/ltunify/ltunify-0.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /app-misc/ltunify/ltunify-0.2-r2.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'app-misc/ltunify/ltunify-0.2-r2.ebuild')
-rw-r--r--app-misc/ltunify/ltunify-0.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/ltunify/ltunify-0.2-r2.ebuild b/app-misc/ltunify/ltunify-0.2-r2.ebuild
new file mode 100644
index 000000000000..55d2dd4a7211
--- /dev/null
+++ b/app-misc/ltunify/ltunify-0.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for working with Logitech Unifying receivers and devices"
+HOMEPAGE="https://lekensteyn.nl/logitech-unifying.html https://git.lekensteyn.nl/ltunify/"
+SRC_URI="https://git.lekensteyn.nl/${PN}/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -i '/^override CFLAGS/d' Makefile || die
+ tc-export CC
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc NEWS README.txt udev/42-logitech-unify-permissions.rules
+}