summaryrefslogtreecommitdiff
path: root/app-misc/lsx/lsx-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/lsx/lsx-0.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/lsx/lsx-0.1-r1.ebuild')
-rw-r--r--app-misc/lsx/lsx-0.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/lsx/lsx-0.1-r1.ebuild b/app-misc/lsx/lsx-0.1-r1.ebuild
new file mode 100644
index 000000000000..8401b8ed3b51
--- /dev/null
+++ b/app-misc/lsx/lsx-0.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="list executables"
+HOMEPAGE="https://tools.suckless.org/lsx"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DOCS=( README )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ # collision with net-dialup/lrzsz
+ mv "${D}/usr/bin/${PN}" "${D}/usr/bin/${PN}-suckless" || die
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "Run ${PN} with ${PN}-suckless"
+}