summaryrefslogtreecommitdiff
path: root/app-misc/lsx/lsx-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-misc/lsx/lsx-0.1-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-misc/lsx/lsx-0.1-r1.ebuild')
-rw-r--r--app-misc/lsx/lsx-0.1-r1.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/app-misc/lsx/lsx-0.1-r1.ebuild b/app-misc/lsx/lsx-0.1-r1.ebuild
index 1cfccc2c3cd2..398cf21908b4 100644
--- a/app-misc/lsx/lsx-0.1-r1.ebuild
+++ b/app-misc/lsx/lsx-0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="list executables"
HOMEPAGE="https://web.archive.org/web/20160104002819/http://tools.suckless.org:80/lsx"
@@ -13,30 +13,25 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-DOCS=( README )
-
src_prepare() {
default
- sed -i \
- -e "s/.*strip.*//" \
- Makefile || die "sed failed"
+ # overengineered build system
+ rm Makefile config.mk || die
+}
- sed -i \
- -e "s/CFLAGS = -Os/CFLAGS +=/" \
- -e "s/LDFLAGS =/LDFLAGS +=/" \
- config.mk || die "sed failed"
+src_configure() {
+ tc-export CC
+ append-cppflags -DVERSION='\"0.1\"'
}
src_compile() {
- emake CC=$(tc-getCC)
+ emake lsx
}
src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
-
# collision with net-dialup/lrzsz
- mv "${D}/usr/bin/${PN}" "${D}/usr/bin/${PN}-suckless" || die
+ newbin ${PN} ${PN}-suckless
einstalldocs
}