summaryrefslogtreecommitdiff
path: root/app-misc/lcdproc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-misc/lcdproc/files
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-misc/lcdproc/files')
-rw-r--r--app-misc/lcdproc/files/LCDd.initd15
-rw-r--r--app-misc/lcdproc/files/LCDd.service10
-rw-r--r--app-misc/lcdproc/files/lcdexec.initd16
-rw-r--r--app-misc/lcdproc/files/lcdexec.service10
-rw-r--r--app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch16
-rw-r--r--app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch15
-rw-r--r--app-misc/lcdproc/files/lcdproc.initd16
-rw-r--r--app-misc/lcdproc/files/lcdproc.service10
8 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/lcdproc/files/LCDd.initd b/app-misc/lcdproc/files/LCDd.initd
new file mode 100644
index 000000000000..792ae9201796
--- /dev/null
+++ b/app-misc/lcdproc/files/LCDd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/sbin/LCDd"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ use g15daemon
+ use net
+}
diff --git a/app-misc/lcdproc/files/LCDd.service b/app-misc/lcdproc/files/LCDd.service
new file mode 100644
index 000000000000..bd53c8cae3cb
--- /dev/null
+++ b/app-misc/lcdproc/files/LCDd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/sbin/LCDd -c /etc/LCDd.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/lcdproc/files/lcdexec.initd b/app-misc/lcdproc/files/lcdexec.initd
new file mode 100644
index 000000000000..b349ae972d83
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdexec.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/bin/lcdexec"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ after ntp-client
+ use LCDd
+ use net
+}
diff --git a/app-misc/lcdproc/files/lcdexec.service b/app-misc/lcdproc/files/lcdexec.service
new file mode 100644
index 000000000000..56ec3dd64cb1
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdexec.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/lcdexec -c /etc/lcdexec.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch b/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch
new file mode 100644
index 000000000000..763038d14ab5
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc-0.5.9-fix-parallel-make.patch
@@ -0,0 +1,16 @@
+--- a/server/drivers/Makefile.am 2017-01-22 23:18:54.000000000 +0100
++++ b/server/drivers/Makefile.am 2018-10-04 22:48:50.302344274 +0200
+@@ -47,11 +47,11 @@
+ futaba_LDADD = @LIBUSB_LIBS@ @LIBUSB_1_0_LIBS@ libLCD.a
+ g15_LDADD = @LIBG15@
+ glcd_LDADD = libLCD.a @GLCD_DRIVERS@ @FT2_LIBS@ @LIBPNG_LIBS@ @LIBSERDISP@ @LIBUSB_LIBS@ @LIBX11_LIBS@
+-glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o
++glcd_DEPENDENCIES = @GLCD_DRIVERS@ glcd-glcd-render.o libLCD.a
+ glcdlib_LDADD = @LIBGLCD@
+ glk_LDADD = libbignum.a
+ hd44780_LDADD = libLCD.a @HD44780_DRIVERS@ @HD44780_I2C@ @LIBUSB_LIBS@ @LIBFTDI_LIBS@ @LIBUGPIO@ libbignum.a
+-hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@
++hd44780_DEPENDENCIES = @HD44780_DRIVERS@ @HD44780_I2C@ libLCD.a libbignum.a
+ i2500vfd_LDADD = @LIBFTDI_LIBS@
+ imon_LDADD = libLCD.a libbignum.a
+ imonlcd_LDADD = libLCD.a
diff --git a/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch b/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch
new file mode 100644
index 000000000000..9149bf784276
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc-0.5.9-use-freetype2-pkg-config.patch
@@ -0,0 +1,15 @@
+--- a/configure.ac 2017-06-18 22:33:56.000000000 +0200
++++ b/configure.ac 2018-10-04 22:30:22.668770478 +0200
+@@ -389,11 +389,7 @@
+ AC_MSG_RESULT($enable_freetype)
+
+ if test "$enable_freetype" = "yes"; then
+- ifdef([AC_CHECK_FT2],
+- [AC_CHECK_FT2([],
+- [AC_DEFINE(HAVE_FT2, [1], [Define to 1 if you have freetype])],
+- [enable_freetype=no])],
+- [AC_MSG_WARN([freetype does not seem to be installed])])
++ PKG_CHECK_MODULES(FT2, freetype2 >= 7.0.1, [enable_freetype="yes"],[enable_freetype="no"])
+ fi
+ AC_SUBST([FT2_CFLAGS])
+ AC_SUBST([FT2_LIBS])
diff --git a/app-misc/lcdproc/files/lcdproc.initd b/app-misc/lcdproc/files/lcdproc.initd
new file mode 100644
index 000000000000..bbeba4033c02
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc.initd
@@ -0,0 +1,16 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+instance="${SVCNAME}"
+name="LCDProc (${instance})"
+pidfile="/run/${instance}.pid"
+
+command="/usr/bin/lcdproc"
+command_args="-c /etc/${instance}.conf"
+
+depend() {
+ after ntp-client
+ use LCDd
+ use net
+}
diff --git a/app-misc/lcdproc/files/lcdproc.service b/app-misc/lcdproc/files/lcdproc.service
new file mode 100644
index 000000000000..f2ee435a169b
--- /dev/null
+++ b/app-misc/lcdproc/files/lcdproc.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=LCDProc (LCDd)
+After=network-online.target
+
+[Service]
+ExecStart=/usr/bin/lcdproc -c /etc/lcdproc.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target