summaryrefslogtreecommitdiff
path: root/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-15 13:19:56 +0100
commitd302a5d7fc9caafba5c8a404f2891bb6ccdec311 (patch)
tree2a3ee43f080d1d0086964de8c29ccf1021fdfda7 /app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
parentea31ad0ed5501d0bf92267c35beaf06ac016bad2 (diff)
gentoo resync : 15.05.2018
Diffstat (limited to 'app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
new file mode 100644
index 000000000000..4465f59fe022
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ app-text/recode
+ sys-apps/grep
+ sys-apps/sed
+ virtual/awk
+ || ( net-misc/wget www-client/lynx )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}