summaryrefslogtreecommitdiff
path: root/app-misc/joy2key/joy2key-1.6.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/joy2key/joy2key-1.6.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/joy2key/joy2key-1.6.3-r1.ebuild')
-rw-r--r--app-misc/joy2key/joy2key-1.6.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/joy2key/joy2key-1.6.3-r1.ebuild b/app-misc/joy2key/joy2key-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..38c8331331cf
--- /dev/null
+++ b/app-misc/joy2key/joy2key-1.6.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An application that translates joystick events to keyboard events"
+HOMEPAGE="https://sourceforge.net/projects/joy2key"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11
+ x11-apps/xwininfo )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_configure() {
+ econf --disable-dependency-tracking $(use_enable X)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog joy2keyrc.sample rawscancodes README TODO
+}