summaryrefslogtreecommitdiff
path: root/app-misc/jdupes/jdupes-1.20.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /app-misc/jdupes/jdupes-1.20.1.ebuild
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'app-misc/jdupes/jdupes-1.20.1.ebuild')
-rw-r--r--app-misc/jdupes/jdupes-1.20.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/jdupes/jdupes-1.20.1.ebuild b/app-misc/jdupes/jdupes-1.20.1.ebuild
new file mode 100644
index 000000000000..681f1d0f1493
--- /dev/null
+++ b/app-misc/jdupes/jdupes-1.20.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://github.com/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}