summaryrefslogtreecommitdiff
path: root/app-misc/ifp-line
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/ifp-line
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/ifp-line')
-rw-r--r--app-misc/ifp-line/Manifest6
-rw-r--r--app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch30
-rw-r--r--app-misc/ifp-line/ifp-line-0.3.ebuild42
-rw-r--r--app-misc/ifp-line/metadata.xml11
4 files changed, 89 insertions, 0 deletions
diff --git a/app-misc/ifp-line/Manifest b/app-misc/ifp-line/Manifest
new file mode 100644
index 000000000000..318ad59d0de2
--- /dev/null
+++ b/app-misc/ifp-line/Manifest
@@ -0,0 +1,6 @@
+AUX ifp-line-0.3-fix-warnings.patch 1082 SHA256 2b94d74719d4c8729a0b7d2c4c91db4cef06bee19afaf5b4d7be8ae5685ac2dd SHA512 58802e40eb866663c5a2f32598ff827fb13bc2f28ea5b73f8a9d59f7013cf62283b7656cfd2d2d2bf796a618d4a56565a9c0a2354f5ad41329ab57780d2b9765 WHIRLPOOL 48b9c4abf08d496d81ca9b9a61d5e645b6aae5702770aab5e2150d5b83b2167d0be42255e226776ac2188457b705da3c338a3d875391963e9ef037f4f4a95b24
+DIST ifp-line-0.3.tar.gz 138272 SHA256 2d44807abbd5d2202d253b550b867dfa3776a71bf6d3f202b0f1254e66325257 SHA512 516ad85fdaf69111581b013b2517c7083656436d429a86ec5ca4b7dcaf1c841538f98138cce8839d990a34550f11cc6bc9dedc701b0123b9cb73a91a7d78694d WHIRLPOOL 868dc9508086a4ba76620d682e1702dded82bf69cd19e42667dac239c6825d0dfb01aaa30d5560e9fe670bf735479b88cae816ab58daa1dacbebe03fa01c05e6
+EBUILD ifp-line-0.3.ebuild 831 SHA256 8d8a81222dd13f3497e547421adba32e5600a1782c9d93ae40ce725a5aa281e8 SHA512 d50131f66ca9ce335db6cd0e855f9b6afed1da3cdddaba783d6be9e3e07146f109bee691a7167dae6a02358ddfd7ed9187d610fb528f19cc1029f46d307304bf WHIRLPOOL 35685540e5680e5a9ff4e5305c92b3c9c9983d1ff66c27913f2139a1b0d8e75384c02c319933783a06b6fe55bf8dfc860a11909c407436756d57277f1a932a5d
+MISC ChangeLog 2466 SHA256 7855434d98490e1edfef34eb1a6cec5f6908c765fc2fc71b18a7003c112b826a SHA512 9109836fc8654c6b1a6e553d0a85abb161119d55a46cc3fa84e205428a8b971c51c78345173205bf01af4f74138edd357867bd9666c7caaacdd7e060c6d70250 WHIRLPOOL 096cb60eba77053be94f1a47f1077504b437dd8660e1d05ab4bae750eb15c4c444b7478ba713d11fdc149be6f36fcdf948aac8e31e0d568e20d13e1ea3fdffdb
+MISC ChangeLog-2015 3119 SHA256 8cff8b0ebf002912bac9398654e5a1b9ea4a36aeef6abae8e27a950371f7fd95 SHA512 00dfbd9ca11a9d2b24bbd48b5a92b958f1d82ce411846bac77d796962e4f778fbe1407e955b8809e8d6c2abe7724ba65edbd4195441e85356f203097d937b670 WHIRLPOOL 943d114d408a22b2c96445fda6325041e7eb53672a04cbd714a7601788bbd8257eda4613b70faef2dae0396074ad3caefc18342b06674203ed33dabbd9023926
+MISC metadata.xml 333 SHA256 44ca1cc7d38d90d325f10c0d53da074abd437d29c6ebb35b21df7af777bf98c4 SHA512 d0cd8f6fc7bdc757d2a1ef5443f30410514ac335bcd2a84829995c527862b994fc75a8dfc5ceff2b8e2a3d7b0b081a57cbc50e4b825567b8a56d0f9eb00c13c7 WHIRLPOOL 782ab0036c5d9ed85791b7fea3c88fb7f4440e11ce1ee6b1e009db433169329d03c1f8daf465c89df98fbb1d911d14166e08a32bdff747d8882bf34fb1a8e6ca
diff --git a/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
new file mode 100644
index 000000000000..f7fe1de4b1ff
--- /dev/null
+++ b/app-misc/ifp-line/files/ifp-line-0.3-fix-warnings.patch
@@ -0,0 +1,30 @@
+--- unicodehack.c.orig 2006-01-31 20:18:16.000000000 -0500
++++ unicodehack.c 2006-01-31 20:18:39.000000000 -0500
+@@ -26,7 +26,7 @@
+ return -1;
+ }
+
+- if ( (retval = iconv(cd, (const char **)&src, &srcln, &dst, &dstln)) == -1) {
++ if ( (retval = iconv(cd, (char **)&src, &srcln, &dst, &dstln)) == -1) {
+ // XXX ignore error message "iconv: Illiegal byte sequence"
+ // with GNU libiconv. No effect for output in now.
+ //perror("iconv");
+@@ -43,7 +43,7 @@
+ /**
+ * @return less then zero: error.
+ */
+-int unicode2locale(char *dst, size_t dstln, const char *src, size_t srcln) {
++int unicode2locale(char *dst, size_t dstln, char *src, size_t srcln) {
+ iconv_t cd;
+ int retval;
+
+--- unicodehack.h.orig 2006-01-31 20:19:05.000000000 -0500
++++ unicodehack.h 2006-01-31 20:19:26.000000000 -0500
+@@ -4,6 +4,6 @@
+ #define IFPLINE_UNICODEHACK_H
+
+ extern int locale2unicode(char*, size_t, const char*, size_t);
+-extern int unicode2locale(char*, size_t, const char*, size_t);
++extern int unicode2locale(char*, size_t, char*, size_t);
+
+ #endif // IFPLINE_UNICODEHACK_H
diff --git a/app-misc/ifp-line/ifp-line-0.3.ebuild b/app-misc/ifp-line/ifp-line-0.3.ebuild
new file mode 100644
index 000000000000..0436505fbe7b
--- /dev/null
+++ b/app-misc/ifp-line/ifp-line-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="iRiver iFP open-source driver"
+HOMEPAGE="http://ifp-driver.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ifp-driver/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-warnings.patch
+}
+
+src_install() {
+ dobin ifp || die
+ dodoc NEWS README TIPS ChangeLog
+ doman ifp.1
+
+ exeinto /usr/share/${PN}
+ doexe nonroot.sh || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To enable non-root usage of ${PN}, you use any of the following"
+ elog "methods."
+ elog
+ elog " 1. Follow the TIPS file in"
+ elog " /usr/share/doc/${PF}"
+ elog
+ elog " 2. Run /usr/share/${PN}/nonroot.sh"
+ elog
+}
diff --git a/app-misc/ifp-line/metadata.xml b/app-misc/ifp-line/metadata.xml
new file mode 100644
index 000000000000..81812cad1e5b
--- /dev/null
+++ b/app-misc/ifp-line/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ifp-driver</remote-id>
+ </upstream>
+</pkgmetadata>