summaryrefslogtreecommitdiff
path: root/app-misc/hyfetch/hyfetch-1.4.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-13 11:40:30 +0000
commit0ded23e9afc3d3424aef90e5cec3f2ca6d6b4c30 (patch)
tree93ef9828fae35063d273f386b2fa4a7130add56b /app-misc/hyfetch/hyfetch-1.4.11.ebuild
parent22b4e2ee9c8011b75d7c030d6129a7487494aeba (diff)
gentoo auto-resync : 13:12:2023 - 11:40:30
Diffstat (limited to 'app-misc/hyfetch/hyfetch-1.4.11.ebuild')
-rw-r--r--app-misc/hyfetch/hyfetch-1.4.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/hyfetch/hyfetch-1.4.11.ebuild b/app-misc/hyfetch/hyfetch-1.4.11.ebuild
new file mode 100644
index 000000000000..5f65e10006ae
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-1.4.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}