summaryrefslogtreecommitdiff
path: root/app-misc/hilite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/hilite
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/hilite')
-rw-r--r--app-misc/hilite/Manifest3
-rw-r--r--app-misc/hilite/hilite-1.5-r1.ebuild33
-rw-r--r--app-misc/hilite/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/hilite/Manifest b/app-misc/hilite/Manifest
new file mode 100644
index 000000000000..de0aea7b8eed
--- /dev/null
+++ b/app-misc/hilite/Manifest
@@ -0,0 +1,3 @@
+DIST hilite-1.5.c 2872 BLAKE2B bd6f89863100906a731008cc3c1b0480e3aa655119d73d651f425a2686ab0a861637f5818c671d453ce26fd831251699e6eb3b59d3e5b5938e2e1cb4de19a367 SHA512 571fb962e430d3c9e5494d802f529529a5bd0bf6dd7f398e7c55dd5a8effc568f9153edecf50d2e296b97eb20b2ddaa52c2214b9dd989449aff3b93a0547ad45
+EBUILD hilite-1.5-r1.ebuild 681 BLAKE2B d848208a9e09d10a110a94d91bd53e1ae9bc860783cf384170cebd9f11463057ba89eeb42224e8c535c086b37b65cf09f8ff85d5cd67bcde95c3da8d70c74c97 SHA512 b789ffcadad98af2d6adf30c49553aea634e7d78d9d764721dc666462f6d769a2bb69b22a84228a4024b243889011545cda5078d1296cf75cdbb66cb3fff4ab2
+MISC metadata.xml 341 BLAKE2B 95a2d672cce1e13ac46dfcc1661b556a241aafdaf9afdb2a5a84afd4ccc94bce8edcf5483f5deda7cb62a834be32be1f7a0fed38d26b96159e4477e668201df0 SHA512 792aa66d85af91677e5d075168e80f3c4d21a804047bcae76e685e612d0c57edf61167712639a5d3322d9f4c35d25b04b6ec2b8d1cd2150d396b8b4e95e8fcad
diff --git a/app-misc/hilite/hilite-1.5-r1.ebuild b/app-misc/hilite/hilite-1.5-r1.ebuild
new file mode 100644
index 000000000000..0eb05fd3e23d
--- /dev/null
+++ b/app-misc/hilite/hilite-1.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility which highlights stderr text in red"
+HOMEPAGE="https://sourceforge.net/projects/hilite"
+SRC_URI="mirror://gentoo/${P}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_prepare() {
+ default
+ cp "${DISTDIR}"/${P}.c "${WORKDIR}"/ || die
+}
+
+src_compile() {
+ ebegin "$(tc-getCC) ${LDFLAGS} ${CFLAGS} -o ${PN} ${P}.c"
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} -o ${PN} ${P}.c || die
+ eend $?
+}
+
+src_install() {
+ dobin "${PN}"
+}
diff --git a/app-misc/hilite/metadata.xml b/app-misc/hilite/metadata.xml
new file mode 100644
index 000000000000..a5ac400c2125
--- /dev/null
+++ b/app-misc/hilite/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>shell-tools@gentoo.org</email>
+ <name>Gentoo Shell Tools Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">hilite</remote-id>
+ </upstream>
+</pkgmetadata>