summaryrefslogtreecommitdiff
path: root/app-misc/hddled/hddled-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/hddled/hddled-0.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/hddled/hddled-0.3.ebuild')
-rw-r--r--app-misc/hddled/hddled-0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/hddled/hddled-0.3.ebuild b/app-misc/hddled/hddled-0.3.ebuild
new file mode 100644
index 000000000000..7197a4970c71
--- /dev/null
+++ b/app-misc/hddled/hddled-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Show hard disk activity using the scroll lock LED"
+HOMEPAGE="http://members.optusnet.com.au/foonly/whirlpool/code/"
+SRC_URI="mirror://gentoo/${P}.c.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+DEPEND="X? ( x11-libs/libX11 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}.c ${PN}.c || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -o ${PN} ${PN}.c ${LDFLAGS} || die
+ if use X ; then
+ $(tc-getCC) ${CFLAGS} -DX -lX11 -o x${PN} ${PN}.c ${LDFLAGS} || die
+ fi
+}
+
+src_install() {
+ dobin ${PN} || die
+ if use X ; then
+ dobin x${PN} || die
+ elog "X version was renamed to x${PN}"
+ fi
+}