summaryrefslogtreecommitdiff
path: root/app-misc/hastyhex/hastyhex-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 21:16:38 +0000
commitf932718a139f93e19a6883c061f81b365a408592 (patch)
tree216b44e4ea101b2d02ea32782355ed127f7b1df4 /app-misc/hastyhex/hastyhex-1.0.0.ebuild
parentf5f1e7d30401ef31b8776c96a80cf5caae0a4e81 (diff)
gentoo auto-resync : 04:11:2022 - 21:16:37
Diffstat (limited to 'app-misc/hastyhex/hastyhex-1.0.0.ebuild')
-rw-r--r--app-misc/hastyhex/hastyhex-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/hastyhex/hastyhex-1.0.0.ebuild b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
new file mode 100644
index 000000000000..87471bff2613
--- /dev/null
+++ b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A blazing fast hex dumper"
+HOMEPAGE="https://github.com/skeeto/hastyhex"
+SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}