summaryrefslogtreecommitdiff
path: root/app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild')
-rw-r--r--app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild b/app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..31512f7fcb2d
--- /dev/null
+++ b/app-misc/hachoir-subfile/hachoir-subfile-0.5.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Find subfile in any binary stream"
+HOMEPAGE="https://bitbucket.org/haypo/hachoir/wiki/hachoir-subfile https://pypi.python.org/pypi/hachoir-subfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/hachoir-core-1.1[${PYTHON_USEDEP}]
+ >=dev-python/hachoir-parser-1.1[${PYTHON_USEDEP}]
+ >=dev-python/hachoir-regex-1.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+ mydistutilsargs=(
+ --setuptools
+ )
+}