summaryrefslogtreecommitdiff
path: root/app-misc/grc/grc-1.11-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/grc/grc-1.11-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/grc/grc-1.11-r1.ebuild')
-rw-r--r--app-misc/grc/grc-1.11-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/grc/grc-1.11-r1.ebuild b/app-misc/grc/grc-1.11-r1.ebuild
new file mode 100644
index 000000000000..516d79b6b948
--- /dev/null
+++ b/app-misc/grc/grc-1.11-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit eutils python-r1
+
+DESCRIPTION="Generic Colouriser beautifies your logfiles or output of commands"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/grc.html"
+SRC_URI="https://github.com/garabik/grc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed \
+ -e 's:#! :#!:g' \
+ -e 's:3$::g' \
+ -i grc grcat || die
+ default
+}
+
+src_install() {
+ python_foreach_impl python_doscript grc grcat
+
+ insinto /usr/share/grc
+ doins \
+ contrib/mrsmith/conf.* \
+ colourfiles/conf.* \
+ grc.bashrc \
+ grc.fish \
+ grc.zsh
+
+ insinto /etc
+ doins grc.conf
+
+ dodoc README.markdown INSTALL TODO debian/changelog CREDITS Regexp.txt
+ doman *.1
+}
+
+pkg_postinst() {
+ elog
+ elog "Shell specific configurations can be found in ${ROOT}usr/share/grc"
+ elog "Be sure to symlink one to use grc globally:"
+ elog
+ elog " ln -s ${ROOT}usr/share/grc.SHELL ${ROOT}etc/profile.d/grc.sh"
+ elog
+ elog "Replace 'SHELL' in the above command with one of: bashrc, fish, zsh."
+ elog "Afterwards, use '. ${ROOT}etc/profile' to activate grc in existing"
+ elog "shell sessions."
+ elog
+}