summaryrefslogtreecommitdiff
path: root/app-misc/graphlcd-base/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/graphlcd-base/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/graphlcd-base/files')
-rw-r--r--app-misc/graphlcd-base/files/graphlcd-base-0.1.5-gcc43.patch312
-rw-r--r--app-misc/graphlcd-base/files/graphlcd-base-0.1.5-nostrip.patch75
2 files changed, 387 insertions, 0 deletions
diff --git a/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-gcc43.patch b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-gcc43.patch
new file mode 100644
index 000000000000..5ec1fa276fae
--- /dev/null
+++ b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-gcc43.patch
@@ -0,0 +1,312 @@
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/avrctl.c graphlcd-base-0.1.5/glcddrivers/avrctl.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/avrctl.c 2008-06-15 14:01:50.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/avrctl.c 2008-06-15 14:02:15.000000000 +0200
+@@ -9,10 +9,11 @@
+ * (c) 2005 Andreas Regel <andreas.regel AT powarman.de>
+ */
+
+ #include <stdint.h>
+ #include <syslog.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "port.h"
+ #include "avrctl.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/config.c graphlcd-base-0.1.5/glcddrivers/config.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/config.c 2008-06-15 14:01:52.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/config.c 2008-06-15 14:02:15.000000000 +0200
+@@ -9,10 +9,12 @@
+ * (c) 2004 Andreas Regel <andreas.regel AT powarman.de>
+ */
+
+ #include <syslog.h>
+ #include <fstream>
++#include <cstring>
++#include <cstdlib>
+
+ #include "common.h"
+ #include "config.h"
+ #include "drivers.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/framebuffer.c graphlcd-base-0.1.5/glcddrivers/framebuffer.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/framebuffer.c 2008-06-15 14:01:53.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/framebuffer.c 2008-06-15 14:02:15.000000000 +0200
+@@ -14,10 +14,12 @@
+ #include <stdio.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <sys/mman.h>
+ #include <sys/ioctl.h>
++#include <cstdlib>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "framebuffer.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/g15daemon.c graphlcd-base-0.1.5/glcddrivers/g15daemon.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/g15daemon.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/g15daemon.c 2008-06-15 14:07:32.000000000 +0200
+@@ -17,10 +17,11 @@
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+ #include <poll.h>
+ #include <arpa/inet.h>
+ #include <unistd.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+
+ #include "g15daemon.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/gu126x64D-K610A4.c graphlcd-base-0.1.5/glcddrivers/gu126x64D-K610A4.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/gu126x64D-K610A4.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/gu126x64D-K610A4.c 2008-06-15 14:08:52.000000000 +0200
+@@ -23,10 +23,12 @@
+
+ #include <errno.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <sys/time.h>
++#include <cstring>
++#include <cstdlib>
+
+ #include "common.h"
+ #include "config.h"
+ #include "gu126x64D-K610A4.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/gu140x32f.c graphlcd-base-0.1.5/glcddrivers/gu140x32f.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/gu140x32f.c 2008-06-15 14:01:53.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/gu140x32f.c 2008-06-15 14:02:15.000000000 +0200
+@@ -19,10 +19,11 @@
+
+ #include <errno.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "gu140x32f.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/gu256x64-372.c graphlcd-base-0.1.5/glcddrivers/gu256x64-372.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/gu256x64-372.c 2008-06-15 14:01:54.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/gu256x64-372.c 2008-06-15 14:02:15.000000000 +0200
+@@ -21,10 +21,11 @@
+
+ #include <errno.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "gu256x64-372.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/gu256x64-3900.c graphlcd-base-0.1.5/glcddrivers/gu256x64-3900.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/gu256x64-3900.c 2008-06-15 14:01:54.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/gu256x64-3900.c 2008-06-15 14:02:15.000000000 +0200
+@@ -27,10 +27,11 @@
+ #include <fcntl.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <termios.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "gu256x64-3900.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/hd61830.c graphlcd-base-0.1.5/glcddrivers/hd61830.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/hd61830.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/hd61830.c 2008-06-15 14:03:34.000000000 +0200
+@@ -9,10 +9,11 @@
+ * (c) 2001-2004 Carsten Siebholz <c.siebholz AT t-online.de>
+ */
+
+ #include <syslog.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "hd61830.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/image.c graphlcd-base-0.1.5/glcddrivers/image.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/image.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/image.c 2008-06-15 14:04:11.000000000 +0200
+@@ -10,10 +10,11 @@
+ * (c) 2004 Andreas Regel <andreas.regel AT powarman.de>
+ */
+
+ #include <stdio.h>
+ #include <syslog.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "image.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/ks0108.c graphlcd-base-0.1.5/glcddrivers/ks0108.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/ks0108.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/ks0108.c 2008-06-15 14:03:45.000000000 +0200
+@@ -9,10 +9,11 @@
+ * (c) 2003 Andreas 'randy' Weinberger <vdr AT smue.org>
+ */
+
+ #include <syslog.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "ks0108.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/network.c graphlcd-base-0.1.5/glcddrivers/network.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/network.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/network.c 2008-06-15 14:08:05.000000000 +0200
+@@ -16,10 +16,11 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <errno.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "network.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/noritake800.c graphlcd-base-0.1.5/glcddrivers/noritake800.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/noritake800.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/noritake800.c 2008-06-15 14:07:04.000000000 +0200
+@@ -32,10 +32,11 @@
+
+ #include <errno.h>
+ #include <syslog.h>
+ #include <unistd.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "noritake800.h"
+ #include "port.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/sed1330.c graphlcd-base-0.1.5/glcddrivers/sed1330.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/sed1330.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/sed1330.c 2008-06-15 14:05:55.000000000 +0200
+@@ -17,10 +17,12 @@
+ * (c) 2003 Roland Praml <praml.roland AT t-online.de>
+ */
+
+ #include <syslog.h>
+ #include <sys/time.h>
++#include <cstring>
++#include <cstdlib>
+
+ #include "common.h"
+ #include "config.h"
+ #include "port.h"
+ #include "sed1330.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/sed1520.c graphlcd-base-0.1.5/glcddrivers/sed1520.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/sed1520.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/sed1520.c 2008-06-15 14:05:31.000000000 +0200
+@@ -9,10 +9,11 @@
+ * (c) 2003 Andreas 'randy' Weinberger <vdr AT smue.org>
+ */
+
+ #include <syslog.h>
+ #include <sys/time.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "port.h"
+ #include "sed1520.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/simlcd.c graphlcd-base-0.1.5/glcddrivers/simlcd.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/simlcd.c 2008-06-15 14:01:55.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/simlcd.c 2008-06-15 14:02:15.000000000 +0200
+@@ -11,10 +11,11 @@
+ * (c) 2001-2004 Carsten Siebholz <c.siebholz AT t-online.de>
+ */
+
+ #include <stdio.h>
+ #include <syslog.h>
++#include <cstring>
+
+ #include "common.h"
+ #include "config.h"
+ #include "simlcd.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcddrivers/t6963c.c graphlcd-base-0.1.5/glcddrivers/t6963c.c
+--- graphlcd-base-0.1.5.orig/glcddrivers/t6963c.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/glcddrivers/t6963c.c 2008-06-15 14:06:33.000000000 +0200
+@@ -10,10 +10,12 @@
+ *
+ * (c) 2003, 2004 Andreas Regel <andreas.regel AT powarman.de>
+ */
+
+ #include <syslog.h>
++#include <cstring>
++#include <cstdlib>
+
+ #include "common.h"
+ #include "config.h"
+ #include "port.h"
+ #include "t6963c.h"
+diff -NrU5 graphlcd-base-0.1.5.orig/glcdgraphics/glcd.c graphlcd-base-0.1.5/glcdgraphics/glcd.c
+--- graphlcd-base-0.1.5.orig/glcdgraphics/glcd.c 2008-06-15 14:01:55.000000000 +0200
++++ graphlcd-base-0.1.5/glcdgraphics/glcd.c 2008-06-15 14:02:15.000000000 +0200
+@@ -14,11 +14,11 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <syslog.h>
+
+-#include <string>
++#include <cstring>
+
+ #include "bitmap.h"
+ #include "glcd.h"
+ #include "image.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/glcdgraphics/pbm.c graphlcd-base-0.1.5/glcdgraphics/pbm.c
+--- graphlcd-base-0.1.5.orig/glcdgraphics/pbm.c 2008-06-15 14:01:55.000000000 +0200
++++ graphlcd-base-0.1.5/glcdgraphics/pbm.c 2008-06-15 14:02:15.000000000 +0200
+@@ -10,12 +10,13 @@
+ */
+
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <syslog.h>
++#include <cstdlib>
+
+-#include <string>
++#include <cstring>
+
+ #include "bitmap.h"
+ #include "pbm.h"
+ #include "image.h"
+
+diff -NrU5 graphlcd-base-0.1.5.orig/tools/convpic/bmp.c graphlcd-base-0.1.5/tools/convpic/bmp.c
+--- graphlcd-base-0.1.5.orig/tools/convpic/bmp.c 2008-06-15 13:47:31.000000000 +0200
++++ graphlcd-base-0.1.5/tools/convpic/bmp.c 2008-06-15 14:09:57.000000000 +0200
+@@ -27,12 +27,12 @@
+ ***************************************************************************/
+
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
+-
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+
+ #include <glcdgraphics/bitmap.h>
+ #include <glcdgraphics/image.h>
+
+ #include "bmp.h"
diff --git a/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-nostrip.patch b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-nostrip.patch
new file mode 100644
index 000000000000..9973394f150b
--- /dev/null
+++ b/app-misc/graphlcd-base/files/graphlcd-base-0.1.5-nostrip.patch
@@ -0,0 +1,75 @@
+remove strip -s in makefile
+
+Joerg Bornkessel <hd_brummy@gentoo.org> 06 April 2007
+diff -Naur graphlcd-base-0.1.5.orig/tools/convpic/Makefile graphlcd-base-0.1.5/tools/convpic/Makefile
+--- graphlcd-base-0.1.5.orig/tools/convpic/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/convpic/Makefile 2007-04-06 20:35:17.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)
+diff -Naur graphlcd-base-0.1.5.orig/tools/crtfont/Makefile graphlcd-base-0.1.5/tools/crtfont/Makefile
+--- graphlcd-base-0.1.5.orig/tools/crtfont/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/crtfont/Makefile 2007-04-06 20:35:32.000000000 +0200
+@@ -35,7 +35,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)
+diff -Naur graphlcd-base-0.1.5.orig/tools/genfont/Makefile graphlcd-base-0.1.5/tools/genfont/Makefile
+--- graphlcd-base-0.1.5.orig/tools/genfont/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/genfont/Makefile 2007-04-06 20:35:43.000000000 +0200
+@@ -38,7 +38,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)
+diff -Naur graphlcd-base-0.1.5.orig/tools/lcdtestpattern/Makefile graphlcd-base-0.1.5/tools/lcdtestpattern/Makefile
+--- graphlcd-base-0.1.5.orig/tools/lcdtestpattern/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/lcdtestpattern/Makefile 2007-04-06 20:35:57.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)
+diff -Naur graphlcd-base-0.1.5.orig/tools/showpic/Makefile graphlcd-base-0.1.5/tools/showpic/Makefile
+--- graphlcd-base-0.1.5.orig/tools/showpic/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/showpic/Makefile 2007-04-06 20:36:09.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)
+diff -Naur graphlcd-base-0.1.5.orig/tools/showtext/Makefile graphlcd-base-0.1.5/tools/showtext/Makefile
+--- graphlcd-base-0.1.5.orig/tools/showtext/Makefile 2007-04-06 20:34:29.000000000 +0200
++++ graphlcd-base-0.1.5/tools/showtext/Makefile 2007-04-06 20:36:21.000000000 +0200
+@@ -36,7 +36,7 @@
+
+ install: $(PRGNAME)
+ install -d $(BINDIR)
+- install -m 755 -o root -g root -s $(PRGNAME) $(BINDIR)
++ install -m 755 -o root -g root $(PRGNAME) $(BINDIR)
+
+ uninstall:
+ rm -f $(BINDIR)/$(PRGNAME)