summaryrefslogtreecommitdiff
path: root/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild')
-rw-r--r--app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
new file mode 100644
index 000000000000..6a318e06fa51
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-2.8.4_p20141112.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/zzamboni/grabcartoons/archive/cb230f01fb288a0b9f0fc437545b97d06c846bd3.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="https://zzamboni.org/code/grabcartoons/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+PATCHES=( "${FILESDIR}"/2.8.4-fix-install-paths.patch )
+
+src_install() {
+ emake PREFIX="${ED%/}"/usr install
+ einstalldocs
+}