summaryrefslogtreecommitdiff
path: root/app-misc/gourmet/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/gourmet/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/gourmet/files')
-rw-r--r--app-misc/gourmet/files/desktop-entry.patch10
-rw-r--r--app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch56
-rw-r--r--app-misc/gourmet/files/no-docs-0.17.0.patch10
-rw-r--r--app-misc/gourmet/files/tostring-to-tobytes.patch26
4 files changed, 102 insertions, 0 deletions
diff --git a/app-misc/gourmet/files/desktop-entry.patch b/app-misc/gourmet/files/desktop-entry.patch
new file mode 100644
index 000000000000..b79aa5f7b770
--- /dev/null
+++ b/app-misc/gourmet/files/desktop-entry.patch
@@ -0,0 +1,10 @@
+--- gourmet.desktop.in
++++ gourmet.desktop.in
+@@ -4,6 +4,6 @@ _Comment=Organize recipes, create shopping lists, calculate nutritional informat
+ Exec=gourmet
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Utility;
++Categories=GNOME;Utility;
+ StartupNotify=true
+ Icon=gourmet
diff --git a/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch b/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch
new file mode 100644
index 000000000000..1547cde8f00d
--- /dev/null
+++ b/app-misc/gourmet/files/gourmet-0.17.4-pyglet.patch
@@ -0,0 +1,56 @@
+diff --git a/gourmet/sound.py b/gourmet/sound.py
+index 2dea6bb7..c232d258 100644
+--- a/gourmet/sound.py
++++ b/gourmet/sound.py
+@@ -1,15 +1,19 @@
+ try:
+- from sound_gst import Player
++ from sound_pyglet import Player
+ except ImportError:
+- print 'No gst player'
++ print 'No pyglet player'
+ try:
+- from sound_windows import Player
++ from sound_gst import Player
+ except ImportError:
+- print 'No windows player'
+- import sys
+- class Player:
+- """Fallback player"""
+- def play_file (self,path):
+- print 'No player installed -- beeping instead'
+- for n in range(5): sys.stdout.write('\a'); sys.stdout.flush()
++ print 'No gst player'
++ try:
++ from sound_windows import Player
++ except ImportError:
++ print 'No windows player'
++ import sys
++ class Player:
++ """Fallback player"""
++ def play_file (self,path):
++ print 'No player installed -- beeping instead'
++ for n in range(5): sys.stdout.write('\a'); sys.stdout.flush()
+
+diff --git a/gourmet/sound_pyglet.py b/gourmet/sound_pyglet.py
+new file mode 100644
+index 00000000..41da613a
+--- /dev/null
++++ b/gourmet/sound_pyglet.py
+@@ -0,0 +1,16 @@
++import pyglet
++
++class Player:
++ def __init__ (self):
++ pass
++
++ def play_file (self,path):
++ self.source = pyglet.media.load(path,streaming=False)
++ self.source.play()
++
++ def stop_play (self,path):
++ pass
++
++if __name__ == '__main__':
++ p = Player()
++ p.play_file('../data/sound/phone.wav')
diff --git a/app-misc/gourmet/files/no-docs-0.17.0.patch b/app-misc/gourmet/files/no-docs-0.17.0.patch
new file mode 100644
index 000000000000..9002a2ef3384
--- /dev/null
+++ b/app-misc/gourmet/files/no-docs-0.17.0.patch
@@ -0,0 +1,10 @@
+--- setup.py 2014-03-02 14:56:56.090600468 -0500
++++ setup.py 2014-03-02 14:57:00.184465687 -0500
+@@ -141,7 +141,6 @@
+
+ files.extend(data_files)
+ files.extend([(os.path.join(base,'ui'), glob.glob(os.path.join('ui','*.ui')))])
+- files.extend([(os.path.join('share','doc','gourmet'), ['FAQ', 'LICENSE'])])
+
+ return files
+
diff --git a/app-misc/gourmet/files/tostring-to-tobytes.patch b/app-misc/gourmet/files/tostring-to-tobytes.patch
new file mode 100644
index 000000000000..e42c59403d51
--- /dev/null
+++ b/app-misc/gourmet/files/tostring-to-tobytes.patch
@@ -0,0 +1,26 @@
+diff --git a/gourmet/gtk_extras/ratingWidget.py b/gourmet/gtk_extras/ratingWidget.py
+index 0e01735..efa6463 100644
+--- a/gourmet/gtk_extras/ratingWidget.py
++++ b/gourmet/gtk_extras/ratingWidget.py
+@@ -135,7 +135,7 @@ class StarGenerator:
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,
+diff --git a/gourmet/plugins/browse_recipes/icon_helpers.py b/gourmet/plugins/browse_recipes/icon_helpers.py
+index 61c772c..2e7b08b 100644
+--- a/gourmet/plugins/browse_recipes/icon_helpers.py
++++ b/gourmet/plugins/browse_recipes/icon_helpers.py
+@@ -38,7 +38,7 @@ def get_pixbuf_from_image (image):
+ if is_rgba: rowstride = 4
+ else: rowstride = 3
+ pb=gtk.gdk.pixbuf_new_from_data(
+- image.tostring(),
++ image.tobytes(),
+ gtk.gdk.COLORSPACE_RGB,
+ is_rgba,
+ 8,