summaryrefslogtreecommitdiff
path: root/app-misc/gnote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /app-misc/gnote
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest2
-rw-r--r--app-misc/gnote/gnote-3.38.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 47e0fd2d033e..c10074652845 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,3 +1,5 @@
DIST gnote-3.36.2.tar.xz 3511244 BLAKE2B d7b8859ec47f8da2d37f285141d4c7fc0f591751a1ebea70339d6cdb727c74a6ca711515f8169130e1b46c1653c0c98da3bc4bce691b8d7a7f2794745e8db2a7 SHA512 6d2e32954836b4ac2800071385eedd6ad391936ee52626b7d51b077e4b4a3e071149804281e645b0fd88dc18e9f3c0f8d53e0994d33875ce5375d6b50b14d5e1
+DIST gnote-3.38.1.tar.xz 3530348 BLAKE2B d3312162ffdf505dea31f8e8848bd755d6fc54a5f95250ce6b90a28e04801fb86a8c4e239471442a4501068a841e38e4764da8f16528849fdec57a88bd271891 SHA512 ccfe35ff3dc8e90fa96307565875401540c9e03a18ffd5b2c25fdb053927c4bb2b6b5515456f5260c053948b1a63bf6959a73e1ab09feefce61ed2adc257734f
EBUILD gnote-3.36.2.ebuild 1546 BLAKE2B 4ce85d4d9ff99dd114b5bec5643d9c438ba77a563c8c878aa72d1fe2e789163960d18910d09273f11861561175d215fb128613d3dfceb192aedeaf16f2406fda SHA512 ef696ad04560cb4d27a7446e19f3d04c9fb8877a227e77c1f7dfc3c47aa2f276db6b7b095dbb484f94911a13a379f41bb298f090c7efb65ad400e2eef6895528
+EBUILD gnote-3.38.1.ebuild 1554 BLAKE2B 4317eb8911e783a1e5f38a2d371b799a8dbaf711fa780e5cbe09b25bddff5637347862a84e552dd6e10469205ca43793d18a14e940f1fc908c95b5279df6cc52 SHA512 22b0d2738388fb6dbb11910e815e66794537d44e2e7f47a8f5b44c35b6b7ff6e3593123317997cf56a4cb0dd0d4c44c6eaac4b63bccec773f11c77422b048329
MISC metadata.xml 342 BLAKE2B 51d98560833845aa6d1f2b9f4c85021fd317434efcd81ba31d106c7b4945acd23cfefc2de2a601ffef3d330adcf93ec0377f69107fa37771d80f7dff056d32ff SHA512 c68c058e279222cc9293a5b97fbf450f95a940a70a32b1adcac3e6276783d2bcc545f39895e92e7bd62c9ac5dc98139dc9800513c2a828895ba1fcf023227d21
diff --git a/app-misc/gnote/gnote-3.38.1.ebuild b/app-misc/gnote/gnote-3.38.1.ebuild
new file mode 100644
index 000000000000..2ebb668cff8b
--- /dev/null
+++ b/app-misc/gnote/gnote-3.38.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Automagic:
+# glib-2.32 dep
+# >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
+COMMON_DEPEND="
+ >=app-crypt/libsecret-0.8
+ >=app-text/gspell-1.6.0:=
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=dev-libs/glib-2.32:2[dbus]
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16:=
+ >=x11-libs/gtk+-3.22.20:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.35.0
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not alter CFLAGS
+ sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
+
+ gnome2_src_prepare
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}