summaryrefslogtreecommitdiff
path: root/app-misc/glastree/glastree-1.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/glastree/glastree-1.04.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/glastree/glastree-1.04.ebuild')
-rw-r--r--app-misc/glastree/glastree-1.04.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/glastree/glastree-1.04.ebuild b/app-misc/glastree/glastree-1.04.ebuild
new file mode 100644
index 000000000000..892b11bc30aa
--- /dev/null
+++ b/app-misc/glastree/glastree-1.04.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
+HOMEPAGE="http://www.igmus.org/code/"
+SRC_URI="http://www.igmus.org/files/${P}.tar.gz"
+DEPEND="dev-lang/perl
+ dev-perl/Date-Calc"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+LICENSE="public-domain"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-posix-make.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/man/man1
+ emake INSTROOT="${D}"/usr INSTMAN=share/man install
+ dodoc README CHANGES THANKS TODO
+}