summaryrefslogtreecommitdiff
path: root/app-misc/getopt/getopt-1.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/getopt/getopt-1.1.6.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/getopt/getopt-1.1.6.ebuild')
-rw-r--r--app-misc/getopt/getopt-1.1.6.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/app-misc/getopt/getopt-1.1.6.ebuild b/app-misc/getopt/getopt-1.1.6.ebuild
deleted file mode 100644
index b81506dc50a1..000000000000
--- a/app-misc/getopt/getopt-1.1.6.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
-HOMEPAGE="http://software.frodo.looijaard.name/getopt/"
-SRC_URI="http://frodo.looijaard.name/system/files/software/getopt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls"
-
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.1.5-libintl.patch
- epatch "${FILESDIR}"/${PN}-1.1.5-setlocale.patch
- epatch "${FILESDIR}"/${PN}-1.1.6-longrename.patch
-
- # hopefully this is portable enough
- epatch "${FILESDIR}"/${PN}-1.1.4-irix.patch
-}
-
-src_compile() {
- local nogettext="1"
- local libintl=""
- local libcgetopt=1
-
- if use nls; then
- nogettext=0
- has_version sys-libs/glibc || libintl="-lintl"
- fi
-
- [[ ${CHOST} == *-aix* ]] && libcgetopt=0
- [[ ${CHOST} == *-irix* ]] && libcgetopt=0
- [[ ${CHOST} == *-interix* ]] && libcgetopt=0
-
- emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
- LIBCGETOPT=${libcgetopt} \
- WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
- CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_install() {
- use nls && emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
-
- newbin getopt getopt-long
-
- # at least on interix, the system getopt is ... broken...
- # util-linux, which would provide the getopt binary, does not build &
- # install on interix/prefix, so, this has to provide it.
- [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
- dosym getopt-long /usr/bin/getopt
-
- newman getopt.1 getopt-long.1
-
- dodoc getopt-*sh
-}