summaryrefslogtreecommitdiff
path: root/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /app-misc/geekcode/geekcode-1.7.3-r1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'app-misc/geekcode/geekcode-1.7.3-r1.ebuild')
-rw-r--r--app-misc/geekcode/geekcode-1.7.3-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-misc/geekcode/geekcode-1.7.3-r1.ebuild b/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
index 861f0cd3f61c..443adb611452 100644
--- a/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
+++ b/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs flag-o-matic
@@ -13,13 +13,14 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+PATCHES=(
+ "${FILESDIR}"/${P}-exit.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
src_prepare() {
- eapply -p0 "${FILESDIR}/${P}-exit.patch"
+ default
sed -i Makefile -e 's| -o | ${LDFLAGS}&|g' || die "sed Makefile"
-
- eapply_user
-
- append-flags -fcommon
}
src_compile() {