summaryrefslogtreecommitdiff
path: root/app-misc/g15daemon/g15daemon-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/g15daemon/g15daemon-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/g15daemon/g15daemon-9999.ebuild')
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild59
1 files changed, 28 insertions, 31 deletions
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
index 71c34ecf83b2..0e442d9fbcdc 100644
--- a/app-misc/g15daemon/g15daemon-9999.ebuild
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -1,26 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-GENTOO_DEPEND_ON_PERL="no"
-ESVN_PROJECT=${PN}/trunk
-ESVN_REPO_URI="https://svn.code.sf.net/p/${PN}/code/trunk/${PN}-wip"
-
-inherit autotools flag-o-matic linux-info perl-module subversion systemd toolchain-funcs udev
+inherit autotools flag-o-matic linux-info perl-module systemd toolchain-funcs udev
DESCRIPTION="Takes control of the G15 keyboard, through the linux kernel uinput device driver"
-HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
-[[ ${PV} = *9999* ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="https://gitlab.com/menelkir/g15daemon"
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/menelkir/g15daemon.git"
+else
+ SRC_URI="https://gitlab.com/menelkir/${PN}/-/archive/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
+# Subslot = libg15daemon_client.so major version
+SLOT="0/3"
IUSE="perl static-libs"
+# Has no "test" target in Makefile
+RESTRICT="test"
+
DEPEND="virtual/libusb:0
- >=dev-libs/libg15-9999
- >=dev-libs/libg15render-9999
+ >=dev-libs/libg15-3.0
+ >=dev-libs/libg15render-3.0
perl? (
dev-lang/perl
dev-perl/GDGraph
@@ -28,17 +33,12 @@ DEPEND="virtual/libusb:0
)"
RDEPEND="${DEPEND}"
-PATCHES=(
- "${FILESDIR}/${PN}-1.9.5.3-g510-keys.patch"
- "${FILESDIR}/${PN}-1.9.5.3-docdir.patch"
- "${FILESDIR}/${PN}-1.9.5.3-avoid_bashisms.patch"
-)
-
uinput_check() {
ebegin "Checking for uinput support"
local rc=1
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
+ eend ${rc}
if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
@@ -59,20 +59,18 @@ pkg_setup() {
}
src_unpack() {
- if [[ ${PV} = *9999* ]] ; then
- subversion_src_unpack
+ if [[ ${PV} == *9999* ]] ; then
+ git-r3_src_unpack
else
- unpack ${A}
+ default
fi
+
if use perl ; then
unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
fi
}
src_prepare() {
- if [[ ${PV} = *9999* ]] ; then
- subversion_wc_info
- fi
if use perl ; then
perl-module_src_prepare
sed -i \
@@ -82,10 +80,7 @@ src_prepare() {
# perl-module_src_prepare always calls base_src_prepare
default
fi
- if [[ ${PV} = *9999* ]] ; then
- mv configure.{in,ac} || die
- eautoreconf
- fi
+ eautoreconf
}
src_configure() {
@@ -117,7 +112,7 @@ src_install() {
rm "${ED}"/usr/share/doc/${PF}/README.usage || die
insinto /usr/share/${PN}/contrib
- doins contrib/xmodmaprc
+ doins contrib/Xmodmap{,-alternative}
doins contrib/xmodmap.sh
if use perl ; then
doins contrib/testbindings.pl
@@ -137,7 +132,7 @@ src_install() {
doexe "${FILESDIR}"/20g15daemon
if use perl ; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ einfo "Installing Perl Bindings (G15Daemon.pm)"
cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install
@@ -145,6 +140,8 @@ src_install() {
}
pkg_postinst() {
+ udev_reload
+
elog "To use g15daemon, you need to add g15daemon to the default runlevel."
elog "This can be done with:"
elog "# /sbin/rc-update add g15daemon default"