summaryrefslogtreecommitdiff
path: root/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/fsniper/fsniper-1.3.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/fsniper/fsniper-1.3.1-r2.ebuild')
-rw-r--r--app-misc/fsniper/fsniper-1.3.1-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/fsniper/fsniper-1.3.1-r2.ebuild b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..55bfb55850f4
--- /dev/null
+++ b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Monitors a given set of directories for new files"
+HOMEPAGE="https://github.com/l3ib/fsniper"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ dev-libs/libpcre
+ sys-apps/file"
+
+RDEPEND="
+ ${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-umask.patch
+)
+
+DOCS=( AUTHORS COPYING NEWS README example.conf )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+}