summaryrefslogtreecommitdiff
path: root/app-misc/fslurp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/fslurp/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/fslurp/files')
-rw-r--r--app-misc/fslurp/files/fslurp-2.1.4-makefile.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
new file mode 100644
index 000000000000..f231c170a4a2
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
@@ -0,0 +1,47 @@
+--- fslurp-2.1.4/Makefile
++++ fslurp-2.1.4/Makefile
+@@ -51,35 +51,35 @@
+ INCLUDES = fslurp.h fronius.h
+ SIMINCLUDES = simulator.h
+
+-DEBUGFLAGS = -g
+-CFLAGS = -c -Wall $(DEBUGFLAGS)
++#DEBUGFLAGS = -g
++CFLAGS += -c -Wall $(DEBUGFLAGS)
+
+-LDFLAGS = -lm
++LIBS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ all: $(TARGETS)
+
+ fslurp: $(FSLURP_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet2i1s: \
+ $(SIMSOLARNET2I1S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet1i0s: \
+ $(SIMSOLARNET1I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet0i0s: \
+ $(SIMSOLARNET0I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simIFCEasy: $(SIMIFCEASY_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ sim422IGTL: $(SIM422IGTL_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ test: $(TARGETS) clean
+ ./testcase.sh