summaryrefslogtreecommitdiff
path: root/app-misc/fslurp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/fslurp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/fslurp/files')
-rw-r--r--app-misc/fslurp/files/fslurp-2.1.4-makefile.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
new file mode 100644
index 000000000000..f231c170a4a2
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
@@ -0,0 +1,47 @@
+--- fslurp-2.1.4/Makefile
++++ fslurp-2.1.4/Makefile
+@@ -51,35 +51,35 @@
+ INCLUDES = fslurp.h fronius.h
+ SIMINCLUDES = simulator.h
+
+-DEBUGFLAGS = -g
+-CFLAGS = -c -Wall $(DEBUGFLAGS)
++#DEBUGFLAGS = -g
++CFLAGS += -c -Wall $(DEBUGFLAGS)
+
+-LDFLAGS = -lm
++LIBS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ all: $(TARGETS)
+
+ fslurp: $(FSLURP_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet2i1s: \
+ $(SIMSOLARNET2I1S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet1i0s: \
+ $(SIMSOLARNET1I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet0i0s: \
+ $(SIMSOLARNET0I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simIFCEasy: $(SIMIFCEASY_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ sim422IGTL: $(SIM422IGTL_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ test: $(TARGETS) clean
+ ./testcase.sh