summaryrefslogtreecommitdiff
path: root/app-misc/freewvs/freewvs-0.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /app-misc/freewvs/freewvs-0.1.3-r1.ebuild
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'app-misc/freewvs/freewvs-0.1.3-r1.ebuild')
-rw-r--r--app-misc/freewvs/freewvs-0.1.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/freewvs/freewvs-0.1.3-r1.ebuild b/app-misc/freewvs/freewvs-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..a8ff9a29ba4d
--- /dev/null
+++ b/app-misc/freewvs/freewvs-0.1.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Scans filesystem for known vulnerable web applications"
+HOMEPAGE="https://freewvs.schokokeks.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+pkg_postinst() {
+ einfo To use freewvs you need to run
+ einfo update-freewvsdb
+ einfo first. You should run this on a regular basis to update
+ einfo the web application data, e.g. via a cronjob.
+}
+
+# Only codingstyle and similar tests, require dependencies
+# not packaged in Gentoo
+RESTRICT="test"