summaryrefslogtreecommitdiff
path: root/app-misc/fdupes/fdupes-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/fdupes/fdupes-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/fdupes/fdupes-9999.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
new file mode 100644
index 000000000000..f27d34c2d82a
--- /dev/null
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic git-r3 toolchain-funcs
+
+MY_P="${PN}-${PV/_pre/-PR}"
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes"
+EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS=""
+SRC_URI=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+DOCS=( CHANGES CONTRIBUTORS README )
+
+src_configure() {
+ append-lfs-flags
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}