summaryrefslogtreecommitdiff
path: root/app-misc/evtest/evtest-1.35.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/evtest/evtest-1.35.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/evtest/evtest-1.35.ebuild')
-rw-r--r--app-misc/evtest/evtest-1.35.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/evtest/evtest-1.35.ebuild b/app-misc/evtest/evtest-1.35.ebuild
new file mode 100644
index 000000000000..96ddf335b126
--- /dev/null
+++ b/app-misc/evtest/evtest-1.35.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="test program for capturing input device events"
+HOMEPAGE="https://cgit.freedesktop.org/evtest/"
+#SRC_URI="https://cgit.freedesktop.org/evtest/snapshot/${PN}-${P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://gitlab.freedesktop.org/libevdev/evtest/-/archive/${P}/${PN}-${P}.tar.bz2"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+BDEPEND="app-text/asciidoc
+ app-text/xmlto"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}