summaryrefslogtreecommitdiff
path: root/app-misc/evemu/evemu-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/evemu/evemu-2.7.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/evemu/evemu-2.7.0.ebuild')
-rw-r--r--app-misc/evemu/evemu-2.7.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/evemu/evemu-2.7.0.ebuild b/app-misc/evemu/evemu-2.7.0.ebuild
new file mode 100644
index 000000000000..8ac8d69567ec
--- /dev/null
+++ b/app-misc/evemu/evemu-2.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit ltprune python-single-r1
+
+DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
+HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/libevdev-1.2.99.902"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable python python-bindings)
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}