summaryrefslogtreecommitdiff
path: root/app-misc/empty/empty-0.6.20b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/empty/empty-0.6.20b.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/empty/empty-0.6.20b.ebuild')
-rw-r--r--app-misc/empty/empty-0.6.20b.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/empty/empty-0.6.20b.ebuild b/app-misc/empty/empty-0.6.20b.ebuild
new file mode 100644
index 000000000000..529bce144e10
--- /dev/null
+++ b/app-misc/empty/empty-0.6.20b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Small shell utility, similar to expect(1)"
+HOMEPAGE="http://empty.sourceforge.net"
+SRC_URI="mirror://sourceforge/empty/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND=""
+RDEPEND="virtual/logger"
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-respect-LDFLAGS.patch"
+ eapply_user
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin empty
+ doman empty.1
+ dodoc README
+ dodoc -r examples
+}