summaryrefslogtreecommitdiff
path: root/app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild')
-rw-r--r--app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild b/app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild
new file mode 100644
index 000000000000..361c762024fa
--- /dev/null
+++ b/app-misc/editor-wrapper/editor-wrapper-4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
+ sed -e 's/@VAR@/PAGER/g' "${FILESDIR}/${P}.sh" >pager || die
+ if use prefix ; then
+ sed -i \
+ -e "s:#!/bin/sh:#!/usr/bin/env sh:" \
+ -e "s: /etc/profile: \"${EPREFIX}/etc/profile\":" \
+ editor pager || die
+ fi
+ eapply_user
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe editor pager
+}