summaryrefslogtreecommitdiff
path: root/app-misc/delay/delay-1.6-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/delay/delay-1.6-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/delay/delay-1.6-r2.ebuild')
-rw-r--r--app-misc/delay/delay-1.6-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/delay/delay-1.6-r2.ebuild b/app-misc/delay/delay-1.6-r2.ebuild
new file mode 100644
index 000000000000..365857916fcf
--- /dev/null
+++ b/app-misc/delay/delay-1.6-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Sleeplike program that counts down the number of seconds specified"
+HOMEPAGE="https://onegeek.org/~tom/software/delay/"
+SRC_URI="https://onegeek.org/~tom/software/delay/dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}"/${P}-headers.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
+
+ mv configure.in configure.ac || die
+
+ default
+ eautoreconf
+}