summaryrefslogtreecommitdiff
path: root/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild')
-rw-r--r--app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild b/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
new file mode 100644
index 000000000000..2a5c6087bcc6
--- /dev/null
+++ b/app-misc/ddccontrol-db/ddccontrol-db-20210812.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="DDCControl monitor database"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="https://github.com/ddccontrol/ddccontrol-db/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-util/intltool
+ dev-perl/XML-Parser
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ touch db/options.xml.h ABOUT-NLS config.rpath || die
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}