summaryrefslogtreecommitdiff
path: root/app-misc/crunch/crunch-3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/crunch/crunch-3.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/crunch/crunch-3.6.ebuild')
-rw-r--r--app-misc/crunch/crunch-3.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/crunch/crunch-3.6.ebuild b/app-misc/crunch/crunch-3.6.ebuild
new file mode 100644
index 000000000000..7488fad701ea
--- /dev/null
+++ b/app-misc/crunch/crunch-3.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="https://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}