summaryrefslogtreecommitdiff
path: root/app-misc/countrycodes/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/countrycodes/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/countrycodes/files')
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
new file mode 100644
index 000000000000..677e59acc5c0
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 9330578..3ff7319 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,13 +26,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC ?= gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++WARNINGS=
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -70,8 +70,10 @@ strip:
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ mkdir -p ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
++ mkdir -p ${mandir}
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
+ @echo