summaryrefslogtreecommitdiff
path: root/app-misc/color/color-1.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/color/color-1.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/color/color-1.2-r1.ebuild')
-rw-r--r--app-misc/color/color-1.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/color/color-1.2-r1.ebuild b/app-misc/color/color-1.2-r1.ebuild
new file mode 100644
index 000000000000..5a0666ada122
--- /dev/null
+++ b/app-misc/color/color-1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin color || die "dobin failed"
+ dodoc CHANGELOG README || die
+
+ # symlink for british users.
+ dosym color /usr/bin/colour || die
+}
+
+pkg_postinst() {
+ elog "For information on using colour in your shell scripts,"
+ elog "run \`color\` without any arguments."
+ elog
+ elog "To see all the colours available, use this command"
+ elog " $ color --list"
+ elog
+ elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
+}