summaryrefslogtreecommitdiff
path: root/app-misc/cmatrix/cmatrix-1.2a-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/cmatrix/cmatrix-1.2a-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/cmatrix/cmatrix-1.2a-r3.ebuild')
-rw-r--r--app-misc/cmatrix/cmatrix-1.2a-r3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/cmatrix/cmatrix-1.2a-r3.ebuild b/app-misc/cmatrix/cmatrix-1.2a-r3.ebuild
new file mode 100644
index 000000000000..d3d8c549c732
--- /dev/null
+++ b/app-misc/cmatrix/cmatrix-1.2a-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix"
+HOMEPAGE="http://www.asty.org/cmatrix"
+SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+IUSE="X"
+
+DEPEND="
+ X? ( x11-apps/mkfontdir )
+ sys-libs/ncurses:0="
+
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ use X && eapply "${FILESDIR}"/${P}-fontdir.patch
+
+ eautoreconf
+}
+
+src_install() {
+ dodir /usr/share/consolefonts
+ dodir /usr/lib/kbd/consolefonts
+ use X && dodir /usr/share/fonts/misc
+
+ default
+}
+
+pkg_postinst() {
+ if use X; then
+ if [[ -d "${ROOT}"usr/share/fonts/misc ]] ; then
+ einfo ">>> Running mkfontdir on ${ROOT}usr/share/fonts/misc"
+ mkfontdir "${ROOT}"usr/share/fonts/misc
+ fi
+ fi
+}