summaryrefslogtreecommitdiff
path: root/app-misc/cdctl/cdctl-0.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/cdctl/cdctl-0.15.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/cdctl/cdctl-0.15.ebuild')
-rw-r--r--app-misc/cdctl/cdctl-0.15.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/cdctl/cdctl-0.15.ebuild b/app-misc/cdctl/cdctl-0.15.ebuild
new file mode 100644
index 000000000000..103a50ff0759
--- /dev/null
+++ b/app-misc/cdctl/cdctl-0.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to control your cd/dvd drive"
+HOMEPAGE="http://cdctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="x86 ppc amd64 ppc64"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.in.patch
+ epatch "${FILESDIR}"/${P}-cdc_ioctls.patch
+}
+
+src_compile() {
+ econf
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS NUTSANDBOLTS PUBLICKEY README
+}